Rename `FixedWidthInteger._random()` to `FixedWidthInteger.random(in: UnboundedRange)`

I see.
It is originally added as a part of FixedWidthInteger but the requirement was removed. Now it's used only in RandomNumberGenerator.next() despite its usefulness.

Signed integer confusion is conceivable. For them, PartialRangeFrom version may be well fit.

But at least we can have UnsignedInteger.random(in: UnboundedRange).
For full range generation we must choose UInt.random(in: 0 ... .max) or Random.default.next(). The former is I described in the first post and the latter will be renamed to longer name.

If we want signed/unsigned integers to have common interface/implementation, simply renaming_random to random is an option.

It seems Random API doesn't encourage using Random.default explicitly. So having alternative for Random.default.next() may fit the policy.