Recommended way to develop for Amazon Linux 2023?

I don't see why not.

That all depends if there will be another 5.9 patch release, and if @mishal_shah is willing to take a late addition, considering it has already been delayed or canceled.

I think you should be able to get it into release/5.10, particularly if you get AL2023 approved as an official platform.

Pretty much, changing this line to (targetTriple.os == .linux && targetTriple.vendor == .amazon) || targetTriple.environment == .android {, after adding amazon to the list of recognized vendors and parser below, should work for the new swift-driver, while similar changes here should update the old C++ Driver.

1 Like