[Proposal draft #2] Naming Functions with Argument Labels

Regarding the alternative syntax of:

aGameView.insertSubview(_, aboveSubview: _)

I find it preferable because:

1. It works with autocomplete nicely. I just autocomplete, then tab and enter '_' for each argument.
2. It doesn’t require thinking about a different syntax to the arguments, it’s more natural just to picture how you would write the method itself, rather than having to write '_:' for the first argument.

For partial application of methods, I would just ignore that use case for now. It’s either call the method, or get a reference to it.

  Patrick Smith

Personal · pgwsmith@gmail.com

Freelance & Products · www.burntcaramel.com
· patrick@burntcaramel.com