Proposal: Add scan, takeWhile, dropWhile, and iterate to the stdlib

Wouldn't droppingFirst() and droppingWhile() satisfy the naming conventions?

The downside is that these are a bit long.

My hesitation with "skip" is that I'm used to "skip" in the context of streams, not collections, i.e. where I'm forwarding a read position (or cursor) while ignoring the elements passed and not returning the rest.

-Thorsten

I think it's more important here to be consistent with the existing methods (e.g. use dropWhile() because we have dropFirst()) and any renaming can be discussed as a separate proposal.

I agree.

-Thorsten