[Pitch] #warning

But doesn't this just defeat the purpose of the proposal? # is the sigil for compiler magic in Swift, and this feature is about having the compiler emit warnings that will allow tooling to hook-into. If you replace this with functions you're forgoing the established convention that # is for compiler magic, and instead we have these magic functions.

If anything it should be:

let somethingSuspect = #warning("This is really the wrong function to call, but I'm being lazy", suspectFunction())