[Pitch] Unify preset static "initializers"

Hi all,

I was wondering the other day why "static initializers", as I will call them, are not unified:



UIColor.blackColor() - which will be UIColor.black() in Swift 3.

... which both do pretty much the same; they are used as convenience initialization for the specific type. I think their intent will be clearer though, when all of them either become static vars (as with CGRect.zero) or static funcs (as with UIColor.black()).

I, though, am not sure which would be the best option.

So I'd like to ask you all two questions:

- Do you think these should be unified? Why (not)?
- If yes, should funcs or vars be used?