Pitch: Fully qualified name syntax

As discussed in the other thread, import aliases evolved into a SwiftPM feature, not a source level feature.

Forcing an import alias seems like it could potentially generate a long tail of renames throughout the codebase, triggered upon the first discovery of a need to resolve ambiguity. Providing a syntax for naming a module directly seems like a much better approach than educating the developer on a workaround.

1 Like

I don’t think the build-level module aliasing feature precludes a source-level one; they’re solving different problems.


Fair, but I don’t think that invalidates my argument that renaming an import at the top of your file(s) is a bit of an indirect solution, and can potentially be a lot of work for a localized situation caused by an upstream dependency. As a point of reference, C# has using aliases but still lets you fully qualify symbols.