This sounds great and should be very useful
So the "process(data:)"
is a string, but really it is going to be typechecked for existence of the function anyway. I wonder if we could skip the ""
and just have it be @...(process(data:), ...)
if that is possible? I'm not sure if that would cause hell for parsing those or not as much.
We discussed with Ben and perhaps the name may use some iteration still? Originally this was discussed as @asyncAlternative
which sounds good as but had the issue that it was confusing to some if "this" function is the async alternative, or the one pointed at is the alternative.
Perhaps we can find some good name for this still though, like @alternative(async: hello(hi:))
or @preferredAlternative(async: hello(hi:))
? Not sure if taking up the alternative name is better or worse than taking the very specific use-case to heart and saying preferredAsyncAlternative(hello(hi:))
though
It might be easier to say this is the @asyncAlternative
after all...?