Syntactically I think it would be better to have async
replace await
directly in an "async let" statement instead of being lifted to be in front of the let
.
e.g:
{
let ok = async "ok",
(yay, nay) = async ("yay", throw Nay())
await ok
try await yay
}