Bee
(Bee)
December 4, 2015, 4:53am
1
Hi all,
Swift is said to be a verbose and easy to read programming language.
However, I see Swift is still using cryptic symbols for logical operators.
! for not
for or
&& for and
Here I propose a new logical operators that are more swiftish.
'not' for not
'or' for or
'and' for and
So, instead of:
if !foo1 || foo2 && foo3 { … }
we could write it as:
if not foo1 or foo2 and foo3 { … }
which is much more readable because it's less cryptic.
What do you think?
Thank you.
Regards,
···
--
-Bee-
There was another post about this earlier today as well:
https://lists.swift.org/pipermail/swift-evolution/2015-December/000032.html
···
--
Keith Smiley
On 12/04, Bee wrote:
Hi all,
Swift is said to be a verbose and easy to read programming language.
However, I see Swift is still using cryptic symbols for logical operators.
! for not
>> for or
&& for and
Here I propose a new logical operators that are more swiftish.
'not' for not
'or' for or
'and' for and
So, instead of:
if !foo1 || foo2 && foo3 { … }
we could write it as:
if not foo1 or foo2 and foo3 { … }
which is much more readable because it's less cryptic.
What do you think?
Thank you.
Regards,
--
-Bee-
_______________________________________________
swift-evolution mailing list
swift-evolution@swift.org
https://lists.swift.org/mailman/listinfo/swift-evolution
Bee
(Bee)
December 4, 2015, 5:03am
3
Oh, I see. Too bad actually.
I'm sorry for not knowing that. I'm a new member here.
···
On Fri, Dec 4, 2015 at 12:01 PM, Keith Smiley <keithbsmiley@gmail.com> wrote:
There was another post about this earlier today as well:
[swift-evolution] Change the name of the boolean operators?
--
Keith Smiley
On 12/04, Bee wrote:
> Hi all,
>
> Swift is said to be a verbose and easy to read programming language.
> However, I see Swift is still using cryptic symbols for logical
operators.
>
> ! for not
> >> for or
> && for and
>
> Here I propose a new logical operators that are more swiftish.
>
> 'not' for not
> 'or' for or
> 'and' for and
>
> So, instead of:
>
> if !foo1 || foo2 && foo3 { … }
>
> we could write it as:
>
> if not foo1 or foo2 and foo3 { … }
>
> which is much more readable because it's less cryptic.
>
> What do you think?
>
> Thank you.
>
> Regards,
>
> --
> -Bee-
> _______________________________________________
> swift-evolution mailing list
> swift-evolution@swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution
--
-Bee-