lldb failure with Swift 4.0 on Ubuntu 16.04


(Edward Connell) #1

I installed the June 7th Ubuntu 16.04 release and performed a clean build
with no problems.

However when I try to debug I get the following error, and then LLDB
terminates.

*LLDBFrontend:
/home/buildnode/disk2/workspace/oss-swift-package-linux-ubuntu-16_04/swift/lib/SIL/TypeLowering.cpp:1693:
const swift::Lowering::TypeLowering
&swift::Lowering::TypeConverter::getTypeLoweringForUncachedLoweredType(swift::Lowering::TypeConverter::TypeKey):
Assertion `key.SubstType->isLegalSILType() && "type is not already
lowered"' failed.*

I installed the June 9th snapshot and it has the same problem. I tested
both Swift 3.1.1 and Swift 4.0 modes, but it fails the same way for both.

Anyone else see this problem?? Any ideas??

Thanks, Ed