Link error when building Swift


(Trevör Anne Denise) #1

I have got an error when trying to build Swift, I got it both for a Ninja build config and now also for the Xcode build config. For the Ninja build config I had finally reset the whole build folder but if that's possible I would have preferred a less time consuming option for Xcode (to avoid rebuilding everything).

Here is there error:

ld: warning: directory not found for option '-L/Volumes/SuperStorage/swift-source/build/Xcode-RelWithDebInfoAssert+swift-DebugAssert/llvm-macosx-x86_64/RelWithDebInfo/lib/Debug'

Undefined symbols for architecture x86_64:

"_cmark_node_get_heading_level", referenced from:

parseHeader(swift::markup::MarkupContext&, swift::markup::LineList&, ParseState) in libswiftMarkup.a(Markup.o)

ld: symbol(s) not found for architecture x86_64

clang: error: linker command failed with exit code 1 (use -v to see invocation)

Do you know if there is something I could do to fix it without cleaning everything?

Thank you and merry Christmas to everyone! :slight_smile:


(Saleem Abdulrasool) #2

My guess is that your cmark is out of sync with the rest of the repositories. You can try updating that, building cmark and then rebuilding swift, which may fix it.


(Trevör Anne Denise) #3

Thank you for your answer!
I ran update-checkout, shouldn't it be in sync? What makes me think they are in sync is that the Ninja build worked once I cleaned all build artefacts. What target should I run to build cmark specifically within Xcode?

Thank you