Latest builds broken?


(Domain Admin) #1

Hi,

this might be a case of user error but I can’t use the latest builds to do
anything (on OSX).

Trying to do a swift build results in the following -

$
/Library/Developer/Toolchains/swift-DEVELOPMENT-SNAPSHOT-2016-03-16-a.xctoolchain/usr/bin/swift-build
dyld: Library not loaded: @rpath/libswiftCore.dylib
  Referenced from:
/Library/Developer/Toolchains/swift-DEVELOPMENT-SNAPSHOT-2016-03-16-a.xctoolchain/usr/bin/swift-build
  Reason: image not found
Trace/BPT trap: 5

At least the 25/02 build works.

When I do an otool -l on the both versions I note that the 25/02 version
has two LC_PATH entries

otool -l
/Library/Developer/Toolchains/swift-DEVELOPMENT-SNAPSHOT-2016-02-25-a.xctoolchain/usr/bin/swift-build
<snip>

Load command 16
          cmd LC_RPATH
      cmdsize 56
         path @executable_path/../lib/swift/macosx (offset 12)
Load command 17
          cmd LC_RPATH
      cmdsize 128
         path
/Users/buildnode/jenkins/workspace/oss-swift-package-osx/build/buildbot_osx/swift-macosx-x86_64/lib/swift/macosx
(offset 12)

Whereas the latest version has only 1

otool -l
/Library/Developer/Toolchains/swift-DEVELOPMENT-SNAPSHOT-2016-03-16-a.xctoolchain/usr/bin/swift-build
<snip>
Load command 17
          cmd LC_RPATH
      cmdsize 128
         path
/Users/buildnode/jenkins/workspace/oss-swift-package-osx/build/buildbot_osx/swift-macosx-x86_64/lib/swift/macosx
(offset 12)

Not sure if this has anything to do with it.

Any help appreciated.

Michael.


(Loïc Lecrenier) #2

Hi Michael,

Yes, the latest build is broken. Here is the bug report: https://bugs.swift.org/browse/SR-975
There is a workaround in the comment, I’ve tested it and it seems to work :slight_smile:

Loïc

···

On Mar 20, 2016, at 10:45 AM, Domain Admin via swift-users <swift-users@swift.org> wrote:

Hi,

this might be a case of user error but I can’t use the latest builds to do anything (on OSX).

Trying to do a swift build results in the following -

$ /Library/Developer/Toolchains/swift-DEVELOPMENT-SNAPSHOT-2016-03-16-a.xctoolchain/usr/bin/swift-build
dyld: Library not loaded: @rpath/libswiftCore.dylib
  Referenced from: /Library/Developer/Toolchains/swift-DEVELOPMENT-SNAPSHOT-2016-03-16-a.xctoolchain/usr/bin/swift-build
  Reason: image not found
Trace/BPT trap: 5

At least the 25/02 build works.

When I do an otool -l on the both versions I note that the 25/02 version has two LC_PATH entries

otool -l /Library/Developer/Toolchains/swift-DEVELOPMENT-SNAPSHOT-2016-02-25-a.xctoolchain/usr/bin/swift-build
  <snip>
Load command 16
          cmd LC_RPATH
      cmdsize 56
         path @executable_path/../lib/swift/macosx (offset 12)
Load command 17
          cmd LC_RPATH
      cmdsize 128
         path /Users/buildnode/jenkins/workspace/oss-swift-package-osx/build/buildbot_osx/swift-macosx-x86_64/lib/swift/macosx (offset 12)

Whereas the latest version has only 1

otool -l /Library/Developer/Toolchains/swift-DEVELOPMENT-SNAPSHOT-2016-03-16-a.xctoolchain/usr/bin/swift-build
<snip>
Load command 17
          cmd LC_RPATH
      cmdsize 128
         path /Users/buildnode/jenkins/workspace/oss-swift-package-osx/build/buildbot_osx/swift-macosx-x86_64/lib/swift/macosx (offset 12)

Not sure if this has anything to do with it.

Any help appreciated.

Michael.
_______________________________________________
swift-users mailing list
swift-users@swift.org
https://lists.swift.org/mailman/listinfo/swift-users