Oftentimes one wishes to assign to a variable a modified version of itself, but a special assignment operator such as
+= does not exist for that particular modification. Unfortunately, for very long variables, this requires writing out the full name on both sides of the equals sign — for instance, to negate a Bool,
some.reallyLong.bool.variable = !some.reallyLong.bool.variable. This is unnecessarily verbose and impairs readability.
I propose the introduction of the keyword
itself to refer to the LHS of an assignment on the RHS. This would allow e.g.,
some.reallyLong.boolean = !itself and
some.reallyLong.int = itself * itself - 1.