Issue with swift-aws-lambda-runtime while building Lambda function

Hello fellow Lambda enthusiasts!

I am trying to work through Fabian Fett's excellent update to deploying a Swift Lambda service. Unfortunately, when I run the following Docker command:

docker run \
    --rm \
    --volume "$(pwd)/:/src" \
    --workdir "/src/" \
    swift:5.3.1-amazonlinux2 \

I get the following error:

Fetching https://github.com/swift-server/swift-aws-lambda-runtime.git
error: Failed to clone https://github.com/swift-server/swift-aws-lambda-runtime.git:
    Cloning into bare repository '/src/.build/repositories/swift-aws-lambda-runtime-c503f180'...
    error: inflate: data stream error (unknown compression method)
    fatal: serious inflate inconsistency
    error: inflate: data stream error (unknown compression method)
    fatal: index-pack failed

Might something be wrong with the hosted Git repo for swift-aws-lambda-runtime?

Thanks!

Woah, that does seem very bad. I am not having any trouble with the clone here. If you try cloning directly do you still have trouble?

Cory, thanks for replying! Yes, that's the odd thing…if I use Tower to clone the repo direct from GitHub, it downloads without issue. For just that reason, I hesitated to post here…this feels like a problem on Rich's end…but I get the same result if I start Fabian's tutorial from scratch. I'm kind of at a loss.

Well, dunno what happened…Docker 3.0.1 update?…the magic of the holiday season?…something else?…but now I'm 100% back in business…able to compile using the AWS Lambda runtime.

Terms of Service

Privacy Policy

Cookie Policy