iOS + experimental-api-diff

Is it possible to use $ swift package experimental-api-diff on an iOS-only package?

I've tried customizing the --sdk and --toolchain options, but I'm still getting errors that suggest that it's using the macOS SDK:

$ swift package experimental-api-diff --toolchain /Library/Developer/Toolchains/swift-5.4.1-RELEASE.xctoolchain --sdk /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS.sdk <commit_to_compare>
...
**error:** the library 'A' requires macos 10.10, but depends on the product 'B' which requires macos 10.15; consider changing the library 'A' to require macos 10.15 or later, or the product 'B' to require macos 10.10 or earlier.
...
Terms of Service

Privacy Policy

Cookie Policy