Failing to build on Swift 5.2

I filed a bug [SR-12448] Cannot build project with Swift 5.2, could for previous Swift versions · Issue #4572 · apple/swift-package-manager · GitHub but wondering if anyone else has ran into this. It's preventing me from updating this repo.

On all previous versions of Swift back since near the beginning of SPM existing, swift build would build on this repo. However, with Swift 5.2 I receive the following error

'AutoGraph' /Users/Rex/Documents/remind101/AutoGraph: error: target at '/Users/Rex/Documents/remind101/AutoGraph' contains mixed language source files; feature not supported

I'm not sure why this started, there is a .h file but there's no .m files in the source at all.

Any assistance will be much appreciated.

The classification of headers was honed due to the pending ability to use resources. I think the error message is semantically correct.

You can use exclude to ignore the header.

1 Like

Thank you for your help. It appears that the .plist files must be excluded. .h is fine though.