Failed to build module, Apple Swift version 5.1.3 have features that aren't supported by this compiler, 'Apple Swift version 5.3.2

Get error in XCode 12.4 on my new Macbook Air M1:

unable to load standard library for target 'arm64-apple-ios8.0' failed to build module 'SciChart' from its module interface; the compiler that produced it, 'Apple Swift version 5.1.3 (swiftlang-1100.0.282.1 clang-1100.0.33.15)', may have used features that aren't supported by this compiler, 'Apple Swift version 5.3.2 (swiftlang-1200.0.45 clang-1200.0.32.28)'

On my old Macbook Pro 2016, with intel chip I don't have any troubles. Both my Macbook have the same XCode version 12.4 and the same Swift version:

Apple Swift version 5.3.2 (swiftlang-1200.0.45 clang-1200.0.32.28)Target: x86_64-apple-darwin20.3.0

What I already done:

  1. Reinstall XCode;
  2. Changed Swift Language Version;
  3. Deleted VALID_ARCHS reference according Xcode 12 Beta 2 - unable to load standard library for target 'arm64-apple-ios14.0-simulator'.

And nothing works to me. Please can you help me! How to solve it?

Which version of SciChart do you have? Based on the podspec files found here, 4.1.0 is the first one that supports arm64 simulators and the last one to support iOS8, you probably need that.

If you have to use earlier version, you can use iOS 13.7 simulator as that will require x64 simulator binaries.

Edit: 4.1.0 doesn't have the 32 bit ios symbols, so it's not good if you want iOS 8 support, 4.2.0 has them (but the minimum iOS version increased to 9)

Terms of Service

Privacy Policy

Cookie Policy