Error building Swift - can't import XCTest

Hey!

I am new to the Swift community and I am right now trying to compile swift from the Github repo. I followed the instructions exactly and everything went fine until I ran ./utils/build-script --release-debuginfo. I left my iMac 2009 10.13.6 running over night and got the following output.

[41/628] Compiling /Users/lh/swift-source/build/Ni...stdlib/public/Darwin/XCTest/macosx/x86_64/XCTest.
... / output intentionally removed by me / ...
/Users/lh/swift-source/swift/stdlib/public/Darwin/XCTest/XCTest.swift:13:19: error: no such module 'XCTest'
@_exported import XCTest // Clang module

Does anyone know what the problem might be? I ran all of the commands in the README.md file and my swift-source looks as follows

$ ls 
build				libcxx				swift				swift-stress-tester
clang				llbuild				swift-corelibs-foundation	swift-syntax
clang-tools-extra		lldb				swift-corelibs-libdispatch	swift-xcode-playground-support
cmark				llvm				swift-corelibs-xctest		swiftpm
compiler-rt			ninja				swift-integration-tests

Does anyone have any idea on how this could be fixed?

hi @Ludwig!

I am facing the same issue... did you figure out what's the cause for this?

Thanks!

I missed this at the time, but can you (both) see what happens when you run xcode-select -p? It's possible we're not configuring stuff right when you have the Command Line Tools package installed.

in my case:

$> xcode-select -p
/Library/Developer/CommandLineTools

I get the exact same output

Okay. Can one of you file a bug? And then the workaround I'd suggest would be deleting the CMakeCache.txt files out of your build directory, and then running build-script again with the DEVELOPER_DIR environment variable set to /Applications/Xcode.app (or wherever your Xcode 10.1 lives).

sure .. will file a bug and try the workaround you suggest.

Thanks Jordan.

$> xcode-select -s /Applications/Xcode.app/Contents/Developer

before re-running the build script would help as well.

bug filed : SR-9669