July 27th is last day for breaking source changes for Swift 3...so I thought I would bring this up one final time.
- .self and .Self do not adequately convey what they do without some mental gymnastics
- self has somewhat two meanings (accessing a property on the type and getting the type of the object)
- We can get into a funky situation where we have self.someVar.self which looks odd (though symmetric!)
- What do we call these two selves? Postfix and prefix self? (I.e. Is it googleable?)
- rename to .type and .Type
- more bikeshedding? There has to be a better way to express these types other than .self and .Self