Difficulty using Bundle.module when packaging apps

I have an app written in swift that uses package manager resources. This works fine when I run it for debugging, but when I try to package the app, I can't get the module resources to load. This is all on a Linux system. Where should I be placing the resources?

You have not provided anywhere near enough information for anyone to troubleshoot your problem. Why don't you link to the code for the app or the swift package?

Okay, sorry for being so unclear. This repository contains a base case of what I'm trying to do: here

Basically, I have some resources, such as ui files, which are handled by the swift package manager. These are then loaded using the Bundle provided by the Bundle.module accessor. This works when I run the app via swift run What I'm trying to do is relocate the executable and bundle so that these resources can still be loaded.

Okay, I had a look on the bug tracker, and it looks like this is due to [https://bugs.swift.org/browse/SR-14555](this bug). I'll try compiling with the 5.5 toolchain, as it looks like that version fixed this issue.

By the way, you got your link syntax mixed up. The square brackets go first, around the link name, followed by the link in parenthesis.

E.g. [google](https://google.com)google

Terms of Service

Privacy Policy

Cookie Policy