Dependencies could not be resolved because package 'yeelampa' is required using a stable-version but 'yeelampa' depends on an unstable-version package 'requester' and root depends on 'yeelampa' 0.1.0

So basically the title. I tried to add my yeelampa project to my app, but this error happened. I have no idea happened. I searched the documentation, but i can't find it in there :(

The author of yeelampa tagged 0.1.0 at an invalid state. While that tag declares itself to be stable, it really is not, because it in turn depends on an unstable reference to requester (such as a branch). Remind the author to make sure all dependency references are stable before tagging releases.

In order to continue your own development while you wait for a repaired 0.1.1 release, you can look up the commit hash of the 0.1.0 tag, and point to that revision instead of the release. In such a state, you will still not be able to tag releases of your own package for the same reason, but you will still be able to resolve, build, test and do most other development tasks.

Big thanks!

Terms of Service

Privacy Policy

Cookie Policy