clang version requirements?


(Tom Gall) #1

Hi All,

Getting my "sea" legs under me building swift and company on Linux.
(Gentoo/x86-64 to be exact). In the docs I see Ubuntu 3.6 r100 as the
minimum mentioned for llvm/clang.

As API and standard support within the llvm/clang/clang++ universe can
change a bit, I was wondering if there was any issues with later
versions such as 3.7 or 3.8?

Thanks!

···

--
Regards,
Tom

"Where's the kaboom!? There was supposed to be an earth-shattering
kaboom!" Marvin Martian
Director, Linaro Mobile Group
Tech Lead, GPGPU
Linaro.org │ Open source software for ARM SoCs
irc: tgall_foo | skype : tom_gall


(Jordan Rose) #2

Hi, Tom. I wouldn't expect 3.7 or 3.8 to cause any problems when used as the compiler building Swift. You'll note that Swift embeds its own version of LLVM and Clang for later use; it will not (and cannot) use the standard one on your system. More information on that is available on the Swift website <https://swift.org/contributing/#llvm-and-swift>.

If you encounter any issues, please bring them up on this list!

Jordan

···

On Jan 4, 2016, at 10:41, Tom Gall via swift-dev <swift-dev@swift.org> wrote:

Hi All,

Getting my "sea" legs under me building swift and company on Linux.
(Gentoo/x86-64 to be exact). In the docs I see Ubuntu 3.6 r100 as the
minimum mentioned for llvm/clang.

As API and standard support within the llvm/clang/clang++ universe can
change a bit, I was wondering if there was any issues with later
versions such as 3.7 or 3.8?

Thanks!

--
Regards,
Tom

"Where's the kaboom!? There was supposed to be an earth-shattering
kaboom!" Marvin Martian
Director, Linaro Mobile Group
Tech Lead, GPGPU
Linaro.org │ Open source software for ARM SoCs
irc: tgall_foo | skype : tom_gall
_______________________________________________
swift-dev mailing list
swift-dev@swift.org
https://lists.swift.org/mailman/listinfo/swift-dev