CI outage today


(Nicole Jacque) #1

Hi All-

This afternoon, we will be temporarily bringing down the CI, starting around 3 PM, California time, in order to upgrade to the beta of Xcode 9 and the associated SDKs. We will also be briefly locking master while we land some source changes in support of the updated SDKs on both master and the swift-4.0-branch. We expect the upgrade process to take an hour or two. We’ll send out a message when the upgrade is complete.

As a reminder, once the upgrade is complete, if you are doing development on a Mac, the minimum required Xcode to build Swift from source will be the Xcode 9 beta. The beta can be downloaded at: https://developer.apple.com/download/

Thanks!
nicole


(Mishal Shah) #2

Hi,

Starting the update process, I will send out another email once completed.

Thanks,
Mishal Shah

···

On Jun 14, 2017, at 11:45 AM, Nicole Jacque via swift-dev <swift-dev@swift.org> wrote:

Hi All-

This afternoon, we will be temporarily bringing down the CI, starting around 3 PM, California time, in order to upgrade to the beta of Xcode 9 and the associated SDKs. We will also be briefly locking master while we land some source changes in support of the updated SDKs on both master and the swift-4.0-branch. We expect the upgrade process to take an hour or two. We’ll send out a message when the upgrade is complete.

As a reminder, once the upgrade is complete, if you are doing development on a Mac, the minimum required Xcode to build Swift from source will be the Xcode 9 beta. The beta can be downloaded at: https://developer.apple.com/download/

Thanks!
nicole

_______________________________________________
swift-dev mailing list
swift-dev@swift.org
https://lists.swift.org/mailman/listinfo/swift-dev


(Mishal Shah) #3

Upgrade completed!

Thanks,
Mishal Shah

···

On Jun 14, 2017, at 3:01 PM, Mishal Shah <mishal_shah@apple.com> wrote:

Hi,

Starting the update process, I will send out another email once completed.

Thanks,
Mishal Shah

On Jun 14, 2017, at 11:45 AM, Nicole Jacque via swift-dev <swift-dev@swift.org <mailto:swift-dev@swift.org>> wrote:

Hi All-

This afternoon, we will be temporarily bringing down the CI, starting around 3 PM, California time, in order to upgrade to the beta of Xcode 9 and the associated SDKs. We will also be briefly locking master while we land some source changes in support of the updated SDKs on both master and the swift-4.0-branch. We expect the upgrade process to take an hour or two. We’ll send out a message when the upgrade is complete.

As a reminder, once the upgrade is complete, if you are doing development on a Mac, the minimum required Xcode to build Swift from source will be the Xcode 9 beta. The beta can be downloaded at: https://developer.apple.com/download/

Thanks!
nicole

_______________________________________________
swift-dev mailing list
swift-dev@swift.org <mailto:swift-dev@swift.org>
https://lists.swift.org/mailman/listinfo/swift-dev