Can't convert to the latest version of Swift because can't find framework module

I have a small macOS application with an embedded framework, both written in Swift. Each has its own Xcode project in separate locations on my Mac, and I use an Xcode workspace to develop and build both at once. I do not use CocoaPods or Carthage. My application and framework build and run successfully.

When I try to convert to the latest version of Swift using the Xcode conversion command, it fails with a "no such module" error for the framework.

My online research shows that "no such module" errors have been plaguing developers who use embedded frameworks for several years. A dozen or more solutions have been suggested online, and they apparently work in some contexts but not in others. None of them work for me.

Has anybody successfully run the Xcode Swift conversion command with an embedded framework and everything written in Swift? If so, can you spell out the key setup features that made it work for you?

···

--

Bill Cheeseman - wjcheeseman@comcast.net

Hi, Bill. I'm afraid I don't have much to help you because this is just supposed to work, and indeed it has worked for a number of projects we've tested locally. You should be able to open the workspace, select the scheme with the application, and convert both targets at once.

Is this a project you're able to share? If so, please file a bug at https://bugreport.apple.com <https://bugreport.apple.com/> and attach both projects and the workspace. (The migrator is considered part of Xcode for now, so we'd rather have bugs go to Apple's bug tracker).

Sorry for the trouble!
Jordan

···

On Aug 28, 2017, at 10:37, Bill Cheeseman via swift-users <swift-users@swift.org> wrote:

I have a small macOS application with an embedded framework, both written in Swift. Each has its own Xcode project in separate locations on my Mac, and I use an Xcode workspace to develop and build both at once. I do not use CocoaPods or Carthage. My application and framework build and run successfully.

When I try to convert to the latest version of Swift using the Xcode conversion command, it fails with a "no such module" error for the framework.

My online research shows that "no such module" errors have been plaguing developers who use embedded frameworks for several years. A dozen or more solutions have been suggested online, and they apparently work in some contexts but not in others. None of them work for me.

Has anybody successfully run the Xcode Swift conversion command with an embedded framework and everything written in Swift? If so, can you spell out the key setup features that made it work for you?

--

Bill Cheeseman - wjcheeseman@comcast.net <mailto:wjcheeseman@comcast.net>
_______________________________________________
swift-users mailing list
swift-users@swift.org
https://lists.swift.org/mailman/listinfo/swift-users