Broken Syntax Highlighting + Code Completion

Hi everybody,

I have a 99% pure Swift 4 project (1% of Objective-C) in Xcode 9 beta 6 and the syntax highlighting and code completion is completely broken. I’m writing here in case it’s a Swift problem and unrelated to Xcode.

Jordan Rose suggested I run Xcode with SOURCEKIT_LOGGING=2 and here are the outputted logs:

default 18:22:07.321659 +0200 com.apple.dt.SKAgent IDEIndexing: SwiftDataSource: No import session for file ‘File1.swift’
default 18:22:07.321659 +0200 com.apple.dt.SKAgent IDEIndexing: SwiftDataSource: No import session for file ‘File2.swift'
// ... one for each file in the project
default 18:22:07.791113 +0200 com.apple.dt.SKAgent IDEIndexing: Failed to get settings for /Users/david/Projects/mimosa.iosapp/Vendor/CleanroomLogger/CleanroomLoggerTests-3B90590B1DAECB5200B4EEC0 - build system did not respond
default 18:22:07.792943 +0200 com.apple.dt.SKAgent IDEIndexing: Failed to get settings for /Users/david/Projects/mimosa.iosapp/Vendor/CleanroomLogger/CleanroomLoggerTests-3B90590B1DAECB5200B4EEC0 - build system did not respond
default 18:22:07.794858 +0200 com.apple.dt.SKAgent IDEIndexing: Failed to get settings for /Users/david/Projects/mimosa.iosapp/Vendor/CleanroomLogger/CleanroomLoggerTests-3B90590B1DAECB5200B4EEC0 - build system did not respond
default 18:22:07.796640 +0200 com.apple.dt.SKAgent IDEIndexing: Failed to get settings for /Users/david/Projects/mimosa.iosapp/Vendor/CleanroomLogger/CleanroomLoggerTests-3B90590B1DAECB5200B4EEC0 - build system did not respond
default 18:22:07.798514 +0200 com.apple.dt.SKAgent IDEIndexing: Failed to get settings for /Users/david/Projects/mimosa.iosapp/Vendor/CleanroomLogger/CleanroomLoggerTests-3B90590B1DAECB5200B4EEC0 - build system did not respond
default 18:22:07.800277 +0200 com.apple.dt.SKAgent IDEIndexing: Failed to get settings for /Users/david/Projects/mimosa.iosapp/Vendor/CleanroomLogger/CleanroomLoggerTests-3B90590B1DAECB5200B4EEC0 - build system did not respond
default 18:22:07.802086 +0200 com.apple.dt.SKAgent IDEIndexing: Failed to get settings for /Users/david/Projects/mimosa.iosapp/Vendor/CleanroomLogger/CleanroomLoggerTests-3B90590B1DAECB5200B4EEC0 - build system did not respond
default 18:22:07.803843 +0200 com.apple.dt.SKAgent IDEIndexing: Failed to get settings for /Users/david/Projects/mimosa.iosapp/Vendor/CleanroomLogger/CleanroomLoggerTests-3B90590B1DAECB5200B4EEC0 - build system did not respond

Any ideas if its a SourceKit or Xcode related issue?

Regards,
David.

I am facing this issue right now. Any pointers on this?

@hartbit Did you figure out the issue and a fix for it?

Terms of Service

Privacy Policy

Cookie Policy