Are there developers out there using Swift on Ubuntu?

I know this is quite a long debugging session already, but does it have the same error message on Ubuntu 20.04 Server?

but does it have the same error message on Ubuntu 20.04 Server?
To be honest - I don't remember. The turn of events was like this:

I was running Ubuntu 21.10 and could not run Swift. So I did clean install of Ubuntu 20.04 and tried Swift again.

I had some compiler crash trying to compile very simple program.

So I gave up and upgraded to 21.10 again.

I had another computer with 18.04 and Swift was running fine there. Since then I have upgraded that computer to 21.10 too.

I do suspect that the crashing on 21.10 and 20.04 are different ones, which is very likely given the major version difference. Also very likely that the 20.04 error is more diagnosable since that's the target environment. If they turn out the be the exact same error, then there's not much more I can do.

Thanks for the info. If I have to do something with Machine Learning - I will definitely check out Swift-Colab.

I run Ubuntu 21.10 using swiftlang.xyz for ARM in a VM - no issues like that.

jocke@linux ~/s/swift-plugin-manager (main) [64]> uname -a

Linux linux 5.13.0-22-generic #22-Ubuntu SMP Fri Nov 5 13:22:27 UTC 2021 aarch64 aarch64 aarch64 GNU/Linux

jocke@linux ~/s/swift-plugin-manager (main)> lsb_release -a

No LSB modules are available.

Distributor ID: Ubuntu

Description: Ubuntu 21.10

Release: 21.10

Codename: impish

jocke@linux ~/s/swift-plugin-manager (main)> swift --version

Swift version 5.5.2 (swift-5.5.2-RELEASE)

Target: aarch64-unknown-linux-gnu

jocke@linux ~/s/swift-plugin-manager (main)>

Swift-Colab isn’t ready for machine learning yet; there’s still a lot of work before S4TF is fully resurrected and our current bug fixes for autodiff are part of a new release toolchain (the only toolchains Swift-Colab can use for the Jupyter kernel). In a few months, it might be viable.

I also used to have problems with the installation from time to time. Until I decided to ignore the documentation and use the Dockerfile as an installation guide. The documentation can be outdated at any time, the Dockerfile is always up to date.

Thanks Daniel,

I may try using Docker when I have time in the future.

For now using the swift-5.5.2-RELEASE-amazonlinux2.tar.gz package works for me.