The review of SE-0158 "Package Manager Manifest API Redesign" ran from March 7 until March 15. The proposal is accepted with the following revisions:
– The "To" in "upToNextMajor" and "upToNextMinor" will be capitalized.
– "upToNextMajor()" and "upToNextMinor()" will name the first parameter "from:" for clarity.
– ".only" will be removed, as it was duplicative versus ".exact".
– We will have cases for ".branch" and ".revision" version specifiers, but will not provide special package initializers with named parameters for these.
This proposal was generally supported, though it did require some discussion and minor revision, and some users are eager for future proposals adding new API not covered by this proposal.
Thanks to everyone who participated!
- Rick Ballard